Mein Versuch den Audacious Port auf Version 1.2 zu heben, endete leider mit der folgenden Fehlermeldung:

>CC     playlist.c                      
playlist.c: In function `playlist_entry_get_info':
playlist.c:181: error: structure has no member named `mtime'
playlist.c:181: error: structure has no member named `mtime'
playlist.c:191: error: structure has no member named `mtime'
playlist.c:208: error: structure has no member named `mtime'
playlist.c: In function `playlist_get_songtitle':
playlist.c:1558: error: structure has no member named `mtime'
playlist.c:1558: error: structure has no member named `mtime'
playlist.c:1558: error: structure has no member named `mtime'
playlist.c: In function `playlist_get_tuple':
playlist.c:1602: error: structure has no member named `mtime'
playlist.c:1602: error: structure has no member named `mtime'
playlist.c:1602: error: structure has no member named `mtime'
playlist.c: In function `playlist_get_songtime':
playlist.c:1634: error: structure has no member named `mtime'
playlist.c:1634: error: structure has no member named `mtime'
playlist.c:1634: error: structure has no member named `mtime'
playlist.c: In function `playlist_fileinfo':
playlist.c:2092: error: structure has no member named `mtime'
playlist.c:2093: error: structure has no member named `mtime'
playlist.c:2093: error: structure has no member named `mtime'
playlist.c: In function `playlist_read_info_selection':
playlist.c:2635: error: structure has no member named `mtime'
gmake[2]: *** [playlist.o] Error 1
gmake[1]: *** [build] Error 2
gmake: *** [build] Error 2
*** Error code 2

Grund des Problems ist scheinbar das Upgrade auf die neue LOCALBASE fürs X11:

Note: Configure has discovered that you already have Audacious installed
and it does not match with the given --prefix. You have Audacious installed
in /usr/X11R6/bin and you chose /usr/local/bin.

Also fix pkg_deinstall audacious && portinstall audacious und alles baut und installiert ohne Probleme :)


Kommentare