Über den HTML-Kurs an sich habe ich ja schon ausführlich berichtet, das kleine Missgeschick am ersten Tag habe ich jedoch bisher verschwiegen. Seit meinem Update auf das neue X.Org 6.9.0 war ich noch nicht wieder in die Verlegenheit gekommen mein Notebook an einem externen Monitor / Beamer zu betreiben. Und siehe da der Beamer verweigerte seinen Dienst, der Inhalt der Konsole war brav zu sehen aber vom X keine Spur. Bisher muss ich sagen habe ich mir darum nie Sorgen gemacht und einfach den Stecker vom Beamer eingesteckt und alles ging.

Diesmal nicht, zum Glück hatte ich die Folien schon als PDF auf der Webseite liegen und konnte also über den Acrobat-Reader der Windowskiste meine Folien zum besten geben, jedoch fehlten somit sämtliche Animationen und das Laden von einigen Seiten ging arg langsam. Die Pausen verbrachte ich also bei Google und mit dem Versuch den VGA-Ausgang in Betrieb zu nehmen. Bis Mittag probierte ich eine ganze Hand voll Tutorials aus und nicht brachte auch nur dein geringsten Effekt, also begann ich mich mit den Fehlern und der Manpage zu beschäftigen was mich dann erstmal darauf brachte, dass das Homeverzeichnis von root ein ganz schlechter Platz für ein Backup der xorg.conf ist, das beim Neustart des Servers als root dann diese dort gesichter Version verwendet wird.

Also probierte ich das ganze noch ein zweites Mal und stellte dabei fest das es eine Menge Tutorials gibt die sich mit dem Xinerama Modus befassen aber keine die einfach nur dem Bildschirm clonen wollen und ich musste mal wieder lernen das am Ende das Lesen der Manpages und das beachten der Fehlermeldungen im Log mehr helfen als alle Tutorials der Welt.

Aber nun des Problems Lösung: Mit dem neuen XOrg 6.9 wird der VGA Ausgang nicht mehr automatisch erkannt und muss erst über die Konfigurationsdatei eingerichtet werden. Dazu muss die Sektion für die Grafikkarte um eine ganze Reihe von Einträgen erweitert werden. Zuallererst muss die Option “MergedFB” aktiviert werden und als zweites der zweite Ausgang konfiguriert werden. In meinem Falle sieht der Eintrag jetzt wie folgt aus:

Section "Device"
    Identifier  "Card0"
    Driver      "ati"
    BusID       "PCI:1:0:0"

    # switch on multiple screen framebuffer
    Option      "MergedFB" "True"
    # set up the screen layout
    Option      "MonitorLayout" "LVDS, CRT"
    # set the vertical refresh rate of the vga device
    Option      "CRT2VRefresh" "50-160"
    # set the horizontal refresh rate of the vga device
    Option      "CRT2HSync" "30-130"
    # clone the primary display
    Option      "CRT2Position" "Clone"
    # allow dynamical clockrate changes
    Option      "DynamicClocks" "True"

    Option      "AGPMode" "4"
EndSection

Wichtig dabei ist es das die vertikale und horizontale Wiederholrate angegeben werden muss, normal versucht der X-Server diese per DDC auszulesen, klappt dies nicht, weil zum Beispiel der Monitor zu alt oder ein manueller Umschalter dazwischen hängt, schaltet der Server immer auf eine Auflösung von 640x480.


Kommentare